XGRIDSDocumentation
  • 简体中文
  • English
  • 繁體中文
  • 日本語
  • Deutsch
  • Español
  • Italiano
  • Français
  • Русский
  • Polski
  • Nederlands
  • 简体中文
  • English
  • 繁體中文
  • 日本語
  • Deutsch
  • Español
  • Italiano
  • Français
  • Русский
  • Polski
  • Nederlands
  • Lixel CyberColor

    • LCC Studio

      • Prise en main
      • Version et mises à jour
      • Téléchargement et installation
      • Aperçu de l’interface et navigation
      • Avant la reconstruction
      • Reconstruction du modèle
      • Reconstruction d’un modèle unique
      • Fusion cartographique
      • Fusion aérienne-terrestre
      • Reconstruction aérienne
      • Mes modèles
      • Autres fonctionnalités
      • Paramètres et compte
      • Convertisseur
      • Reconstruction vidéo
      • Questions fréquentes
    • LCC Scene Editor

      • Version et mises à jour
      • Compte et connexion
      • Présentation du produit et accueil
      • Interface de l’éditeur
      • Modes de navigation de scène
      • Fichier
      • Paramètres
      • Opérations d’édition
      • Fenêtre
      • Barre d’outils globale
      • Ressources et propriétés
      • Barre d’outils gauche
      • Points de vue
      • Portail
      • Skybox
      • Annotations
      • Mesure
      • Parcours
      • Rapport de scène
      • 3D Layout
      • Mini-carte
      • Mode Prévisualisation, Viewer
      • Aide
      • FAQ
      • Point d’apparition
    • LCC Model Editor

      • Version et mises à jour
      • Guide de l’utilisateur
      • Aperçu et interface
      • Opérations sur les fichiers
      • Sélecteurs
      • Modification des modèles
      • Mesure
      • Réglage des couleurs
      • Gestion des ressources
      • Paramètres et aide
      • Questions fréquentes
    • Bonnes Pratiques

      • Fusion de plusieurs modèles 3DGS de grande taille
  • Plugin & SDK

    • Unreal

      • Introduction
      • Démarrage rapide - Windows
      • Démarrage rapide - Linux
      • Démarrage rapide - Quest3
      • Éditions et licences
      • Rendu
      • Rastérisation Tiled (expérimental)
      • Réglages visuels
      • Normales et éclairage
      • Édition de scène
      • Paramètres de performance
      • Guide d'optimisation des performances
      • Intégration avec les plugins tiers et moteur
      • Maillage proxy
      • Animation de chargement
      • Collision
      • Prise en charge du système de navigation
      • Prise en charge de l'eau à couche unique
      • Localisation
      • Questions fréquentes
      • Dépannage
      • Journaux et diagnostics
      • Nous contacter
      • Bonnes pratiques

        • Rééclairer un 3DGS avec un maillage LixelStudio
      • Référence API

        • ALCCActorBase
        • ULCCComponentBase
        • ULCCComponent
        • ULCC2Component
        • Actors SOG / SPZ / PLY
        • ALCC2ProxyMesh
        • ALCCClippingVolume
        • ALCCSectionPlane
        • ALCCLoadVolume
        • ULCCUtilLibrary
        • Enums
        • Structs
      • Journal des modifications

        • v3.4.0
        • v3.3.1
        • v3.0.0
        • v2.2.1
        • v1.0.0
        • v0.9.0
        • v0.8.0
        • v0.7.1
        • v0.6.1
        • v0.5.2
        • v0.4.1
        • v0.4.0
        • v0.3.0
        • v0.0.5
        • v0.0.4
        • v0.0.3
        • v0.0.2
        • v0.0.1
    • Unity

      • Introduction au SDK Unity
      • Fonctionnalités techniques
      • Exigences de l'environnement de développement
      • Guide de démarrage rapide PC
      • Guide d'optimisation des paramètres de projet
      • Guide de développement Pico 4 Ultra
      • Guide de streaming PC du Pico 4 Ultra
      • Guide de développement Quest 3
      • Guide de streaming PC du Quest 3
      • Guide de développement OpenXR
      • Guide Business Streaming du Pico 4 Ultra
      • Glossaire
      • FAQ
      • Nous contacter
      • Guide de développement des fonctionnalités

        • Guide de développement du rendu mixte multi-scènes
        • Guide de développement de la réception des ombres
        • Guide de développement de l'éclairage en temps réel
        • Guide de développement du rendu multi-caméras
        • Guide de développement du rendu d'images haute résolution
        • Guide de développement de la compatibilité des formats de données LCC et LCC2
        • Guide de développement de l'effet de chargement
        • Guide de développement du basculement du mode de rendu Mip
        • Guide de développement de l'accrochage aux arêtes et aux coins
        • Guide de développement du décalque projeté
        • Guide de développement du décalque projeté vidéo
        • Guide de développement du surlignage
        • Guide de développement de la découpe en temps réel
        • Guide de développement du réglage des couleurs
        • Guide de développement de l'obtention des données Mesh de la scène
        • Guide de développement du mode éditeur
        • Guide de configuration des paramètres de performance de rendu
        • Guide de développement du co-packageage de l'application et des données
        • Guide de développement du système de collision
        • Guide des problèmes d'autorisation de développement macOS
        • Guide de développement de la compilation et du packageage sur appareil iOS
      • Référence de l'API

        • LCCManager
        • Renderer
        • Types de données
      • Journal des modifications

        • v2.3.0
        • v2.2.10
        • v2.2.0
        • v2.1.19
        • v2.0.14

Guide de démarrage rapide PC

Importez le LCC Unity SDK et rendez une scène 3DGS dans Unity à partir de zéro.

Prérequis

Avant de commencer, assurez-vous que votre ordinateur de développement satisfait aux exigences matérielles et de version de Unity, et que vous avez obtenu le package LCC Unity SDK. Voir Exigences de l'environnement de développement pour plus de détails.

  • Version de Unity : entièrement testé et vérifié sur Unity 2022.3.62f1, Unity 6000.0.69f1 et Unity 6000.5.9f1
  • Pipeline de rendu : testé et vérifié sur le pipeline Built-in et le pipeline de rendu universel (URP)
  • Le package LCC Unity SDK a été téléchargé (Téléchargement du SDK).

Flux de travail de base

Étape 1 : Créer un projet URP

En prenant Unity 6.0 LTS comme exemple, créez un projet Universal 3D (URP).

La version Built-in du LCC Unity SDK prend en charge Unity 2022.3 LTS (incluant les pipelines Built-in et URP) ; les autres versions ne prennent en charge que les pipelines URP. Lors de la création d'un projet avec Unity 6.0 LTS ou version ultérieure, veillez à sélectionner le modèle Universal 3D.

Créer un projet Universal 3D (URP) avec Unity 6.0 LTS

Créer un projet Universal 3D (URP) avec Unity 6.0 LTS

Étape 2 : Importer le package LCC SDK

  1. Dans Unity, ouvrez le Package Manager via Fenêtre → Package Manager.
  2. Cliquez sur le bouton + dans le coin supérieur gauche et sélectionnez Install package from disk.
Sélectionner Install package from disk dans le Package Manager

Sélectionner Install package from disk dans le Package Manager

  1. Dans la boîte de dialogue de fichier qui apparaît, naviguez jusqu'à l'emplacement du package LCC SDK, sélectionnez son fichier package.json, puis cliquez sur Ouvrir pour importer le package.
Sélectionner le fichier package.json du package à importer

Sélectionner le fichier package.json du package à importer

  1. Unity commence à importer le package LCC SDK. Une fois l'importation terminée, sélectionnez Samples dans le panneau d'importation du package pour importer les exemples d'utilisation.
Importer les Samples dans le panneau d'importation du package

Importer les Samples dans le panneau d'importation du package

À ce stade, l'importation du package LCC SDK est terminée.

Étape 3 : Configurer l'API graphique

Ouvrez le panneau des paramètres via Édition → Paramètres du projet → Player, sélectionnez l'entrée Other sous l'onglet de la plateforme correspondante, et configurez l'API graphique pour chaque plateforme :

PlateformeAction
WindowsDécochez Auto Graphics API for Windows et ajoutez DirectX12, Vulkan et DirectX11
macOSDécochez Auto Graphics API for Mac et conservez Metal
LinuxDécochez Auto Graphics API for Linux et conservez Vulkan
Configurer l'API graphique pour chaque plateforme dans les paramètres Player

Configurer l'API graphique pour chaque plateforme dans les paramètres Player

Remarque : privilégiez Gamma pour l'espace colorimétrique (Color Space).

Étape 4 : Ouvrir la scène d'exemple

Ouvrez la scène d'exemple importée, située par défaut dans Projet → Samples/LCC SDK/X.X.X/LCC SDK/LCCViewer (X.X.X est le numéro de version du package).

Ouvrir la scène LCCViewer dans l'exemple

Ouvrir la scène LCCViewer dans l'exemple

Remarque :

Dans la scène ouverte, sélectionnez le GameObject LCCManager dans le panneau Hiérarchie ; vérifiez dans la fenêtre Inspecteur si le composant LCCManager est attaché (dans certains cas, le composant peut être perdu), et si ce n'est pas le cas, ajoutez-le via Ajouter un composant.

Étape 5 : Définir le chemin des données

Dans la scène ouverte, sélectionnez le GameObject LCCRenderer dans le panneau Hiérarchie ; dans le panneau Inspecteur, pointez le champ File Path du script LCC Renderer vers le répertoire de données. Notez qu'il doit pointer directement vers le fichier xxx.lcc2.

Définir le File Path du LCC Renderer dans l'Inspecteur

Définir le File Path du LCC Renderer dans l'Inspecteur

Remarque :

Dans la scène ouverte, vérifiez si la propriété Manager du composant LCCRenderer attaché au GameObject LCCRenderer a le composant LCCManager assigné (dans certains cas, la référence peut être perdue), et si ce n'est pas le cas, faites glisser le GameObject LCCManager sur cette propriété.

Syntaxe de chemin pour les différentes plateformes (exemples) :

PlateformeSyntaxe de cheminExemple
WindowsUtilisez des doubles barres obliques inversées \\
ou une seule barre oblique inversée \
G:\\GaussianSplat\\0315-art-center\\xxx.lcc2
macOSUtilisez des barres obliques //users/data/lcc/xxx.lcc2
ServeurUtilisez des barres obliques /https://xgus1.blob.core.windows.net/lcc-pub/Tower/xxx.lcc2

Remarque :

  1. Le Transform du LCCRenderer doit correspondre à l'image ci-dessus, ce qui l'aligne avec le système de coordonnées des données. Si ce GameObject est créé via le code, définissez également sa Rotation et son Scale pour qu'ils correspondent à l'image ci-dessus.
  2. En raison du système de coordonnées des données, dans Unity, le Transform du GameObject qui porte le Renderer doit être défini comme indiqué ci-dessus (cela peut également être fait à l'exécution dans le code). Pour plus de détails sur l'alignement du système de coordonnées, voir « Système de coordonnées des données LCC » dans Introduction au SDK Unity.

Étape 6 : Ajuster la gestion des entrées

Unity 6.0 LTS et versions ultérieures utilisent Input System par défaut, tandis que la caméra des Samples utilise Input Manager ; le mode de gestion des entrées doit donc être ajusté.

Ouvrez le panneau des paramètres via Édition → Paramètres du projet → Player, trouvez Active Input Handling sous la section Other Settings, et définissez-le sur Both.

Définir Active Input Handling sur Both

Définir Active Input Handling sur Both

Étape 7 : Exécuter

Cliquez sur le bouton Lecture dans Unity, et vous verrez la scène rendue.

La scène 3DGS rendue après l'exécution

La scène 3DGS rendue après l'exécution