XGRIDSDokumentation
  • 简体中文
  • English
  • 繁體中文
  • 日本語
  • Deutsch
  • Español
  • Italiano
  • Français
  • Русский
  • Polski
  • Nederlands
  • 简体中文
  • English
  • 繁體中文
  • 日本語
  • Deutsch
  • Español
  • Italiano
  • Français
  • Русский
  • Polski
  • Nederlands
  • Lixel PortalCam-Serie

    • PortalCam P1

      • Produktübersicht
      • Grundlegende Bedienung
      • LCC Scan App verwenden
      • Wartung und Pflege
      • FAQ
  • Lixel K-Serie

    • Lixel K1

      • Produktübersicht
      • Grundlegende Bedienung
      • Geräteaktivierung und -verbindung
      • Scan-Workflow
      • Punktwolke mit absoluten Koordinaten erfassen
      • Kartenfusion
      • Empfehlungen zur Routenplanung für typische Szenen
      • Hinweise
      • FAQ
    • Lixel K2

      • Produktübersicht
      • Grundlegende Bedienung
      • Aktivierung und Verbindung
      • Scan-Workflow
      • Punktwolke mit absoluten Koordinaten erfassen
      • Kartenfusion
      • Empfehlungen zur Routenplanung für typische Szenen
      • Hinweise
      • FAQ
  • Lixel L-Serie

    • Lixel L2 Pro

      • Produktübersicht
      • Grundlegende Bedienung
      • Geräteaktivierung und -verbindung
      • Scan-Workflow
      • Punktwolke mit absoluten Koordinaten erfassen
      • Messpunkt
      • Anhang
      • FAQ
    • Lixel L3

      • Produktübersicht
      • Grundlegende Bedienung
      • Aktivierung und Verbindung
      • Scan-Workflow
      • Punktwolke mit absoluten Koordinaten erfassen
      • Anhang
  • Zubehör

    • Stick Light

      • Installationsanleitung
      • Grundlegende Bedienung
      • Häufige Fragen
  • Lixel Studio

    • Version und Copyright
    • Installation und Aktivierung
    • Softwareoberfläche
    • Dateioperationen
    • Projektverarbeitung
    • Werkzeuge
    • 2D-Zeichnung
    • Anwendungen
    • Einstellungen
    • Geräteverbindung
    • Häufige Fragen
  • Lixel CyberColor

    • LCC Studio

      • Erste Schritte
      • Version und Updates
      • Download und Installation
      • Oberfläche und Navigation
      • Vor der Rekonstruktion
      • Modellrekonstruktion
      • Einzelmodell-Rekonstruktion
      • Kartenfusion
      • Boden-Luft-Fusion
      • Luftbild-Rekonstruktion
      • Meine Modelle
      • Weitere Funktionen
      • Einstellungen und Konto
      • Converter
      • Videorekonstruktion
      • Häufige Fragen / FAQ
    • LCC Scene Editor

      • Version und Updates
      • Konto und Anmeldung
      • Produktübersicht und Startseite
      • Editor-Oberfläche
      • Navigationsmodi
      • Datei
      • Einstellungen
      • Bearbeiten
      • Fenster
      • Globale Symbolleiste
      • Assets und Eigenschaften
      • Linke Symbolleiste
      • Ansichtspunkte
      • Portal
      • Skybox
      • Markierungen
      • Messung
      • Flythrough
      • Szenenbericht
      • 3D-Layout
      • Minikarte
      • Vorschaumodus (Viewer)
      • Hilfe
      • Häufige Fragen (FAQ)
      • Spawn-Point
    • LCC Model Editor

      • Version und Updates
      • Benutzerhandbuch
      • Übersicht und Oberfläche
      • Dateioperationen
      • Selektoren
      • Modelle bearbeiten
      • Messung
      • Farbkorrektur
      • Asset-Verwaltung
      • Einstellungen und Hilfe
      • Häufige Fragen
    • Capture Guide

      • Überblick
      • Überblick über die Aufnahmegeräte
      • Allgemeine Aufnahmeprinzipien
      • Aufnahme von Innenszenen
      • Aufnahme von Außenszenen
      • Großflächige Aufnahme (Map Fusion)
      • Aerial-Ground Map Fusion – Aufnahme
      • Objektaufnahme
      • Personenaufnahme
      • Video-Rekonstruktionsaufnahme
      • HD Enhancement
      • Kontrollpunkte (Lixel P1)
      • FAQ und Fehlerbehebung
    • Best Practices

      • Zusammenführen mehrerer großer 3DGS-Modelle
    • Versionsgeschichte
  • Plugin & SDK

    • Unreal

      • Einführung
      • Schnellstart - Windows
      • Schnellstart - Linux
      • Schnellstart - Quest3
      • Editionen und Lizenzierung
      • Rendering
      • Tiled-Rasterisierung (experimentell)
      • Bildeinstellungen
      • Normalen und Beleuchtung
      • Szenenbearbeitung
      • Leistungsparameter
      • Leitfaden zur Leistung
      • Integration von Drittanbieter- und Engine-Plugins
      • Proxy Mesh
      • Ladeanimation
      • Kollision
      • Unterstützung des Navigation System
      • Unterstützung von Single Layer Water
      • Lokalisierung
      • FAQ
      • Fehlerbehebung
      • Logs und Diagnose
      • Kontakt
      • Bewährte Vorgehensweisen

        • 3DGS mit einem LixelStudio-Mesh neu beleuchten
      • API-Referenz

        • ALCCActorBase
        • ULCCComponentBase
        • ULCCComponent
        • ULCC2Component
        • SOG- / SPZ- / PLY-Actors
        • ALCC2ProxyMesh
        • ALCCClippingVolume
        • ALCCSectionPlane
        • ALCCLoadVolume
        • ULCCUtilLibrary
        • Enums
        • Structs
      • Änderungsprotokoll

        • v3.4.0
        • v3.3.1
        • v3.0.0
        • v2.2.1
        • v1.0.0
        • v0.9.0
        • v0.8.0
        • v0.7.1
        • v0.6.1
        • v0.5.2
        • v0.4.1
        • v0.4.0
        • v0.3.0
        • v0.0.5
        • v0.0.4
        • v0.0.3
        • v0.0.2
        • v0.0.1
    • Unity

      • Einführung in das Unity SDK
      • Technische Funktionen
      • Anforderungen an die Entwicklungsumgebung
      • PC-Schnellstartanleitung
      • Leitfaden zur Optimierung der Projekteinstellungen
      • Pico 4 Ultra-Entwicklungsanleitung
      • Pico 4 Ultra-PC-Streaming-Anleitung
      • Quest 3-Entwicklungsanleitung
      • Quest 3-PC-Streaming-Anleitung
      • OpenXR-Entwicklungsanleitung
      • Pico 4 Ultra-Business-Streaming-Anleitung
      • Glossar
      • FAQ
      • Kontakt
      • Funktionsentwicklungsleitfaden

        • Entwicklungsanleitung für gemischtes Multi-Szenen-Rendering
        • Entwicklungsanleitung für Schattenempfang
        • Entwicklungsanleitung für Echtzeitbeleuchtung
        • Entwicklungsanleitung für Multi-Kamera-Rendering
        • Entwicklungsanleitung für hochauflösendes Bild-Rendering
        • Entwicklungsanleitung zur Kompatibilität der Datenformate LCC und LCC2
        • Entwicklungsanleitung für Ladeeffekte
        • Entwicklungsanleitung für das Umschalten des Mip-Rendering-Modus
        • Entwicklungsanleitung für Kanten- und Eckensnapping
        • Entwicklungsanleitung für projizierte Decals
        • Entwicklungsanleitung für projizierte Video-Decals
        • Entwicklungsanleitung für Hervorhebung
        • Entwicklungsanleitung für Echtzeit-Clipping
        • Entwicklungsanleitung für Farbanpassung
        • Entwicklungsanleitung für das Abrufen von Szenen-Mesh-Daten
        • Entwicklungsanleitung für den Editor-Modus
        • Konfigurationsanleitung für Render-Leistungsparameter
        • Entwicklungsanleitung zum gemeinsamen Paketieren von Anwendung und Daten
        • Entwicklungsanleitung für das Kollisionssystem
        • Anleitung zu macOS-Berechtigungsproblemen in der Entwicklung
        • Entwicklungsanleitung für Kompilierung und Paketierung auf iOS-Geräten
      • API-Referenz

        • LCCManager
        • Renderer
        • Datentypen
      • Changelog

        • v2.3.0
        • v2.2.10
        • v2.2.0
        • v2.1.19
        • v2.0.14
    • Web

      • Einführung
      • Leitfaden zur Rendering-Leistungsoptimierung
      • Grafikkonfiguration
      • Häufige Fragen
      • API-Referenz

        • LCCRender::clearIndexDB
        • LCCRender::dispose
        • LCCRender::load
        • LCCRender::setCamera
        • LCCRender::unload
        • LCCRender::update
        • LCCObject::checkRenderNextFrame
        • LCCObject::clearRenderNextFrame
        • LCCObject::ecef2Prj
        • LCCObject::getBounds
        • LCCObject::getEnvInstancedMesh
        • LCCObject::getInstancedMesh
        • LCCObject::getLodInfos
        • LCCObject::getOriginPosition
        • LCCObject::getProjectionCoordinateSystemInfos
        • LCCObject::hasCollision
        • LCCObject::hasEnvironment
        • LCCObject::hasShcoef
        • LCCObject::intersectsCapsule
        • LCCObject::intersectsRayExt
        • LCCObject::intersectsRayFromOriginExt
        • LCCObject::intersectsSphere
        • LCCObject::lowerToBottom
        • LCCObject::prj2Ecef
        • LCCObject::raiseToTop
        • LCCObject::raycast
        • LCCObject::raycastFromOrigin
        • LCCObject::setAlpha
        • LCCObject::setClipBox
        • LCCObject::setClipPlane
        • LCCObject::setEndLod
        • LCCObject::setLodAutoLevelUp
        • LCCObject::setMaxDistance
        • LCCObject::setMaxNodeSplats
        • LCCObject::setMaxSplats
        • LCCObject::setOriginPosition
        • LCCObject::setPointsColor
        • LCCObject::setRenderState
        • LCCObject::setRotation
        • LCCObject::setScale
        • LCCObject::setSemantic
        • LCCObject::setSemanticColor
        • LCCObject::setSmooth
        • LCCObject::setStartLod
        • LCCObject::setTranslation
        • LCCObject::setVisible
        • LCCObject::togglePointsDisplayMode
        • LCCObject::useEnvironment
        • LCCObject::useShcoef
      • Änderungsprotokoll

        • v0.6.3
        • v0.6.2
        • v0.6.1
        • v0.6.0
        • v0.5.5
        • v0.5.4
        • v0.5.3
        • v0.5.2
        • v0.5.1
        • v0.5.0
        • v0.4.1
        • v0.4.0
        • v0.3.1
        • v0.3.0
        • v0.2.0

PC-Schnellstartanleitung

Das LCC Unity SDK importieren und eine 3DGS-Szene in Unity von Grund auf rendern.

Voraussetzungen

Stellen Sie vor dem Beginn sicher, dass Ihr Entwicklungsrechner die Hardware- und Unity-Versionsanforderungen erfüllt und dass Sie das LCC Unity SDK-Paket bezogen haben. Details finden Sie unter Anforderungen an die Entwicklungsumgebung.

  • Unity-Version: vollständig getestet und verifiziert auf Unity 2022.3.62f1, Unity 6000.0.69f1 und Unity 6000.5.9f1
  • Render-Pipeline: getestet und verifiziert auf der Built-in-Pipeline und der Universal Render Pipeline (URP)
  • Das LCC Unity SDK-Paket wurde heruntergeladen (SDK-Download).

Grundlegender Ablauf

Schritt 1: Ein URP-Projekt erstellen

Erstellen Sie am Beispiel von Unity 6.0 LTS ein Universal 3D-Projekt (URP).

Die Built-in-Version des LCC Unity SDK unterstützt Unity 2022.3 LTS (einschließlich Built-in- und URP-Pipeline); andere Versionen unterstützen nur die URP-Pipelines. Achten Sie beim Erstellen eines Projekts mit Unity 6.0 LTS oder neuer darauf, die Vorlage „Universal 3D“ auszuwählen.

Ein Universal-3D-Projekt (URP) mit Unity 6.0 LTS erstellen

Ein Universal-3D-Projekt (URP) mit Unity 6.0 LTS erstellen

Schritt 2: Das LCC SDK-Paket importieren

  1. Öffnen Sie in Unity den Paket-Manager über Fenster → Paket-Manager.
  2. Klicken Sie oben links auf die Schaltfläche + und wählen Sie Paket von Datenträger installieren.
Im Paket-Manager „Paket von Datenträger installieren“ auswählen

Im Paket-Manager „Paket von Datenträger installieren“ auswählen

  1. Navigieren Sie im erscheinenden Dateidialog zum Speicherort des LCC SDK-Pakets, wählen Sie dessen Datei package.json und klicken Sie auf Öffnen, um das Paket zu importieren.
Die Datei package.json im zu importierenden Paket auswählen

Die Datei package.json im zu importierenden Paket auswählen

  1. Unity beginnt mit dem Import des LCC SDK-Pakets. Wählen Sie nach Abschluss des Imports im Paket-Importbereich Samples, um die Nutzungsbeispiele zu importieren.
Die Samples im Paket-Importbereich importieren

Die Samples im Paket-Importbereich importieren

Damit ist der Import des LCC SDK-Pakets abgeschlossen.

Schritt 3: Die Grafik-API konfigurieren

Öffnen Sie das Einstellungsfenster über Bearbeiten → Projekteinstellungen → Player, wählen Sie im Tab der jeweiligen Plattform den Eintrag Weitere Einstellungen und konfigurieren Sie die Grafik-API pro Plattform:

PlattformAktion
WindowsAutomatische Grafik-API für Windows deaktivieren und DirectX12, Vulkan und DirectX11 hinzufügen
macOSAutomatische Grafik-API für Mac deaktivieren und Metal beibehalten
LinuxAutomatische Grafik-API für Linux deaktivieren und Vulkan beibehalten
Die Grafik-API für jede Plattform in den Player-Einstellungen konfigurieren

Die Grafik-API für jede Plattform in den Player-Einstellungen konfigurieren

Hinweis: Bevorzugen Sie Gamma als Farbraum.

Schritt 4: Die Beispielszene öffnen

Öffnen Sie die importierte Beispielszene; sie befindet sich standardmäßig unter Projekt → Samples/LCC SDK/X.X.X/LCC SDK/LCCViewer (X.X.X ist die Paketversionsnummer).

Die Szene LCCViewer im Sample öffnen

Die Szene LCCViewer im Sample öffnen

Hinweis:

Wählen Sie in der geöffneten Szene das GameObject LCCManager im Fenster Hierarchie aus; prüfen Sie im Fenster Inspektor, ob die Komponente LCCManager angehängt ist (in manchen Fällen kann die Komponente verloren gehen), und fügen Sie sie andernfalls über Komponente hinzufügen hinzu.

Schritt 5: Den Datenpfad festlegen

Wählen Sie in der geöffneten Szene das GameObject LCCRenderer im Fenster Hierarchie aus; richten Sie im Fenster Inspektor die Eigenschaft File Path des LCC Renderer-Skripts auf das Datenverzeichnis. Beachten Sie, dass sie direkt auf die Datei xxx.lcc2 zeigen muss.

Den File Path des LCC Renderer im Inspektor festlegen

Den File Path des LCC Renderer im Inspektor festlegen

Hinweis:

Prüfen Sie in der geöffneten Szene, ob die Eigenschaft Manager der am GameObject LCCRenderer angehängten Komponente LCCRenderer mit der Komponente LCCManager belegt ist (in manchen Fällen kann die Referenz verloren gehen), und ziehen Sie andernfalls das GameObject LCCManager auf diese Eigenschaft.

Pfadsyntax für die verschiedenen Plattformen (Beispiele):

PlattformPfadsyntaxBeispiel
WindowsDoppelte Backslashes \\
oder einen einzelnen Backslash \ verwenden
G:\\GaussianSplat\\0315-art-center\\xxx.lcc2
macOSSchrägstriche / verwenden/users/data/lcc/xxx.lcc2
ServerSchrägstriche / verwendenhttps://xgus1.blob.core.windows.net/lcc-pub/Tower/xxx.lcc2

Hinweis:

  1. Die Transform des LCCRenderer muss dem obigen Bild entsprechen, wodurch sie am Daten-Koordinatensystem ausgerichtet wird. Wird dieses GameObject per Code erstellt, müssen Rotation und Scale ebenfalls dem obigen Bild entsprechen.
  2. Aufgrund des Daten-Koordinatensystems muss in Unity die Transform des GameObjects, das den Renderer trägt, wie oben dargestellt gesetzt werden (dies kann zur Laufzeit auch per Code erfolgen). Details zur Ausrichtung am Koordinatensystem finden Sie unter „LCC-Daten-Koordinatensystem“ in Einführung in das Unity SDK.

Schritt 6: Die Eingabeverarbeitung anpassen

Unity 6.0 LTS und neuer verwenden standardmäßig das Eingabesystem (Input System), während die Kamera in den Samples den Input Manager verwendet; daher muss der Modus der Eingabeverarbeitung angepasst werden.

Öffnen Sie das Einstellungsfenster über Bearbeiten → Projekteinstellungen → Player, suchen Sie im Abschnitt Weitere Einstellungen die Option Aktive Eingabeverarbeitung und stellen Sie sie auf Beides.

Aktive Eingabeverarbeitung auf „Beides“ einstellen

Aktive Eingabeverarbeitung auf „Beides“ einstellen

Schritt 7: Ausführen

Klicken Sie in Unity auf die Schaltfläche Play, und Sie sehen die gerenderte Szene.

Die gerenderte 3DGS-Szene nach dem Ausführen

Die gerenderte 3DGS-Szene nach dem Ausführen